BUG dans une Chaîne

Voir le sujet précédent Voir le sujet suivant Aller en bas

BUG dans une Chaîne

Message par linkakro le Jeu 27 Oct - 12:13

Ce bug est semble-t-il la cause de tous mes problèmes concernant mon crypteur d'image en chaîne.
J'ai cherché la raison longtemps, aussi bien lors de la création du code il y a quelques mois que lors de son adaptation pour le jeu d'Halloween.
J'ai fini par trouver cette piste :

"FV"->Str2
"FV" est traîté comme un seul caractère ! que je passe mon curseur dessus ou en utilisant sub(Str2,1,1) qui donne FV au lieu de F :shock: :shock: :shock:
Du moins à l'intérieur de mon programme.

Quand je recopie manuellement ces caractère dans un quelconque émulateur avec une quelconque rom (83/83+), le bug est absent.
Mais dès que j'insère ceci dans un de mes émulateurs via un programme, ça bug : FV au lieu de F !

Quand je corrige la chaîne dans l'émulateur manuellement puis que j'extrait le programme, et enfin que je le réinsère, le bug n'apparaît point.
Il s'agit probablement d'une confusion de compilation entre mon éditeur Ti-Connect et mes émulateurs VTI et Wabbitemu.

Tant pis si j'écrit pour rien mais ça me défoule.


Dernière édition par linkakro le Jeu 27 Oct - 12:23, édité 1 fois (Raison : J'ai avancé dans mes recherches)

linkakro
Or 4
Or 4

Sexe : Masculin
Age : 22
Messages : 768
Date d'inscription : 01/07/2010
Etudes : dut geii (elec/info)
Points Forum : 51
Points Concours : 8
Langages :
  • - TI-Basic Z80
  • - ASM TI-82 Stats / TI-83
  • - ASM TI-83+ / TI-84+
Calculatrices :
  • - TI-82 Stats.fr
  • - TI-84 Pocket.fr

TI-84+ SE


Revenir en haut Aller en bas

Re: BUG dans une Chaîne

Message par Alexis le Jeu 27 Oct - 17:17

C'est sûrement à cause de la variable PV dans la finance.

_________________
L'administrateur du forum.

Salut Invité, tu as posté 11 messages sur le forum.

Mes projets:
[Vous devez être inscrit et connecté pour voir cette image]

[Vous devez être inscrit et connecté pour voir cette image]

[Vous devez être inscrit et connecté pour voir cette image]

Alexis
Platinum 2
Platinum 2

Sexe : Masculin
Age : 23
Messages : 2320
Date d'inscription : 28/06/2010
Etudes : DUT Informatique
Points Forum : 40
Points Concours : 3
Langages :
  • - TI-Basic Z80
  • - ASM TI-82 Stats / TI-83
  • - Axe Parser
Calculatrices :
  • - TI-Collège
  • - TI-82 Stats.fr
  • - TI-84+

TI-84+


http://espace-ti.e-monsite.com

Revenir en haut Aller en bas

Re: BUG dans une Chaîne

Message par linkakro le Jeu 27 Oct - 17:56

C'est génial !!! MERCI !!! :D

Ta révélation m'a fait réaliser plusieurs causes de ce bug dans mon programme de cyptage.
Depuis le temps que je bosse dessus, ça fait plaisir !!! :D

J'avais déjà contourné le problème avec FV, maintenant je vais tenter de l'appliquer avec toutes les autres confusions.

DS<(
racine cubique
FV
PV
PMT
P/Y
C/Y

Sous réserve d'en trouver d'autres.

linkakro
Or 4
Or 4

Sexe : Masculin
Age : 22
Messages : 768
Date d'inscription : 01/07/2010
Etudes : dut geii (elec/info)
Points Forum : 51
Points Concours : 8
Langages :
  • - TI-Basic Z80
  • - ASM TI-82 Stats / TI-83
  • - ASM TI-83+ / TI-84+
Calculatrices :
  • - TI-82 Stats.fr
  • - TI-84 Pocket.fr

TI-84+ SE


Revenir en haut Aller en bas

Re: BUG dans une Chaîne

Message par Contenu sponsorisé Aujourd'hui à 2:23


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum